Commit 4d8b80d5 authored by Andreas Valder's avatar Andreas Valder

Merge branch 'crackwitz/website-requirementstxt'

parents d042c961 bf3e7115
......@@ -6,7 +6,7 @@ Hinweis: diese Variante startet eine lokale Testversion der Website, es sind nic
1. Repo Clonen
2. Verzeichnis betreten
3. (optional) config.py.example anpassen und als config.py neu speichern
3. (optional) config.py.example anpassen und als config.py neu speichern (z.B. DEBUG = True)
4. Schauen, ob alle Dependencies erfüllt sind (siehe weiter unten)
5. `./run.py` ausführen
6. Unter [http://localhost:5000](http://localhost:5000) ist die Website verfügbar
......@@ -35,7 +35,7 @@ Origin stellt hier euren User da, Upstream das Original der Gruppe videoagwebsit
### Abhängigkeiten
Notwendig:
* python (Version 3)
* sqlite
* sqlite3 (Python builtin)
* python-flask
* python-requests (wird vom L2P und vom Kalenderimport verwendet, kann nicht optional eingebunden werden)
* git (zum Anzeigen der aktuellen Version)
......@@ -43,10 +43,13 @@ Notwendig:
Optional (wird für einzelne Features benötigt):
* python-lxml (Campus- und RO-Import)
* python-pytz (RO-Import)
* python-ldap (Login mit Fachschaftsaccount)
* python-ldap3 (Login mit Fachschaftsaccount)
* python-icalendar (RO-Import, Kalenderimport für Sitzungsankündigungen)
* python-mysql-connector (wenn MySQL als Datenbank verwendet werden soll)
* python-coverage (Für Coverage Tests benötigt)
Kurzform unter Ubuntu:
`sudo apt install python3 python3-flask sqlite python3-requests python3-lxml python3-ldap3 python3-icalendar python3-mysql.connector`
Mit python-eigenem Paketmanager:
`pip install -r requirements.txt`
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment